Firewall

Priorizar resultados de SpeedTest.Net a través de Mikrotik Queue

Prueba de velocidad


Como lo implementó ayer, un viejo truco, NADA NUEVO realmente.

(Aunque personalmente no veo ninguna razón por la que dar prioridad a tales resultados speed.test.net, para falsificar a quién, cliente o usted mismo? Lol)

A continuación se muestra una sencilla demostración de cómo priorizar la prueba de velocidad speedtest.net.
Escenario: Se permite que el cliente obtenga 512k, pero cuando acceda a speedtest.net para comprobar la velocidad, podrá ver 2mb, (cada usuario podrá comprobarlo en 2mb de límite, individualmente por ip) mientras su normal La descarga / navegación permanecerá bajo el límite de cola de 512k como se muestra en la imagen anterior.

ROS CODE, probado con las versiones 5.x y 6.x:

# Mark speedtest in Layer7 firewall
/ip firewall layer7-protocol
add name=speedtest regexp="^.+(speedtest).*\\\$"
 
# Marking SPEEDTEST.NET in mangle section using L7
/ip firewall mangle
add action=mark-connection chain=forward comment=SPEEDTEST layer7-protocol=speedtest new-connection-mark=speedtest_conn
add action=mark-connection chain=prerouting new-connection-mark=speedtest_conn protocol=tcp src-port=8080
add action=mark-packet chain=prerouting connection-mark=speedtest_conn new-packet-mark=speedtest_pkt passthrough=no
add action=mark-connection chain=postrouting dst-port=8080 new-connection-mark=speedtest_conn protocol=tcp
add action=mark-packet chain=postrouting connection-mark=speedtest_conn new-packet-mark=speedtest_pkt passthrough=no
 
# ADD PCQ so that i can be applied on per ip bases later in simple queue / zaib
/queue type
add kind=pcq name=download-2mb pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=2048k \
    pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=upload-2mb pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=2048k \
    pcq-src-address-mask=32 pcq-src-address6-mask=64 pcq-total-limit=2000
 
# Add simple QUEUE to limit speedtest.net 2mb PER USER
/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s comment="Limit every Users at 2mb using PCQ. for speedtest only marked by mangle / zaib" direction=both disabled=no interface=all limit-at=0/0 max-limit=0/0 name=\
    "SpeedTest.Net 2Mb per use via g PCQ / zaib" packet-marks=speedtest_pkt parent=none priority=8 queue=upload-2mb/download-2mb target-addresses=192.168.5.0/24 total-queue=default-small
 
# Add simple QUEUE to limit user PC individually for rest of traffic, static or dynamic up to your network.
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both disabled=no interface=all limit-at=512k/512k max-limit=512k/512k name="Zaib Desktop 512k A llowed - 192.168.5.2" packet-marks="" \
    parent=none priority=8 queue=default-small/default-small target-addresses=192.168.5.2/32 total-queue=default-small

Mover la cola speedtest.net en la parte superior! El ordenar es muy importante en mikrotik, pues las reglas se procesan orden sabio, cero a la parte inferior

Nota: Puede ajustarse más lejos en PCQ, ÁRBOL DE LA COLA, etc etc según la red diseñada.


cliente

 


Fuente : AACable

About the author

Richard M.