Home Voip

Mikrotik – Priorizar VoIP con IP/PBX Grandstream

Nivel: Intermedio

Este articulo aborda el tema de Voz IP de tal modo que aunque tengas un gran uso del Upload de tu servicio de internet no afecte a la calidad del audio.

Cabe mencionar que con fibra salvo en casos muy extraños te encuentres con el problema de un Upload reducido, aplica mas que nada para adsl o similares.

Utilizando el marcado de paquetes de Mikrotik tenemos dos formas de hacerlo:

1- Conociendo la IP de nuestro conmutador o centralita telefónica

2- Usando etiquetado DSCP.

Ambos métodos son muy sencillos de realizar

En este articulo usaremos el ejemplo de DSCP 48 para SIP y RTP (para información sobre ToS Y DSCP ). En el UCM de Grandstream pueden marcar con DSCP distinto SIP o RTP  realmente para la voz lo que nos preocupa es RTP, pero consideraremos el mismo etiquetado para ambos protocolos.

primero vamos a indicar en el UCM el tipo de calidad de servicio(ToS) que usaremos para los protocolos SIP y RTP(tanto para voz y vídeo)

A continuación abrimos Winbox e ingresamos a nuestro Mikrotik.

Primero crearemos unas reglas para marcar los paquetes, abrimos terminal e ingresamos el siguiente código:

/ip firewall mangle
add action=mark-packet chain=prerouting comment=VOIP dscp=48 new-packet-mark=voip-mark passthrough=no
add action=mark-packet chain=prerouting comment=VOIP new-packet-mark=Resto_trafico passthrough=no

Ahora crearemos las colas correspondientes para que una vez marcados los paquetes se encolen tomando en consideración que VoIP será mas prioritario que el resto de tráfico.

queue tree
add name=Cola_principal parent=ether1 priority=1 queue=default
add limit-at=1M max-limit=2M name=Trafico_VOIP packet-mark=voip-mark parent=Cola_principal priority=1 queue=ethernet-default
add limit-at=8M max-limit=10M name=Trafico_Restante packet-mark=”Resto_trafico” parent=Cola_principal priority=8 queue=default

Fuente : SYSCOM

About the author

Richard M.